using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)[ ]([\*&]+)([a-zA-Z])";
string substitution = @"$1$2 $3";
string input = @"const char *name,;
char **argv
const SomeType &some_value
value * other";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}