// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+)[ ]([\*&]+)([a-zA-Z])").unwrap();
let string = "const char *name,;
char **argv
const SomeType &some_value
value * other";
let substitution = "$1$2 $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}