#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\|\w+;(Data\d+;\d+;\d+)"
Local $sString = ""12121|a;Data1;234;121|b;Data2;235;122|c;Data3;236;123;[-]mass1;112;1212;1212;1212;1212"" & @CRLF & _
"" & @CRLF & _
"----" & @CRLF & _
"Data1;234;121" & @CRLF & _
"Data2;235;122" & @CRLF & _
"Data3;236;123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")