package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|\w+;(Data\d+;\d+;\d+)`)
var str = `"12121|a;Data1;234;121|b;Data2;235;122|c;Data3;236;123;[-]mass1;112;1212;1212;1212;1212"
----
Data1;234;121
Data2;235;122
Data3;236;123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}