$re = '/\|\w+;(Data\d+;\d+;\d+)/m';
$str = '"12121|a;Data1;234;121|b;Data2;235;122|c;Data3;236;123;[-]mass1;112;1212;1212;1212;1212"
----
Data1;234;121
Data2;235;122
Data3;236;123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);