const regex = /\|\w+;(Data\d+;\d+;\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|\\w+;(Data\\d+;\\d+;\\d+)', 'gm')
const str = `"12121|a;Data1;234;121|b;Data2;235;122|c;Data3;236;123;[-]mass1;112;1212;1212;1212;1212"
----
Data1;234;121
Data2;235;122
Data3;236;123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}