// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\|\w+;(Data\d+;\d+;\d+)").unwrap();
let string = "\"12121|a;Data1;234;121|b;Data2;235;122|c;Data3;236;123;[-]mass1;112;1212;1212;1212;1212\"
----
Data1;234;121
Data2;235;122
Data3;236;123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}