#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?<days>\d+(?= д.))?(?<hours>\d+(?= ч.))?(?<minutes>\d+(?= м.))?"
Local $sString = "5 д. 1 ч. 23 м." & @CRLF & _
"17 ч. 44 м." & @CRLF & _
"12 д. 17 ч."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")