use strict;
my $str = '5 д. 1 ч. 23 м.
17 ч. 44 м.
12 д. 17 ч.';
my $regex = qr/(?<days>\d+(?= д.))?(?<hours>\d+(?= ч.))?(?<minutes>\d+(?= м.))?/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}