import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<days>\\d+(?= д.))?(?<hours>\\d+(?= ч.))?(?<minutes>\\d+(?= м.))?";
final String string = "5 д. 1 ч. 23 м.\n"
+ "17 ч. 44 м.\n"
+ "12 д. 17 ч.";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}