$re = '/(?<days>\d+(?= д.))?(?<hours>\d+(?= ч.))?(?<minutes>\d+(?= м.))?/u';
$str = '5 д. 1 ч. 23 м.
17 ч. 44 м.
12 д. 17 ч.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);