re = /(?<days>\d+(?= д.))?(?<hours>\d+(?= ч.))?(?<minutes>\d+(?= м.))?/
str = '5 д. 1 ч. 23 м.
17 ч. 44 м.
12 д. 17 ч.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end