using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)[0-9a-z~!@#$%^&*\(\)\-_+=\|\}\{\]\[\;:\/?.,]{12,}(?:['|\""|\n|\r|\s|\x60]|$)";
string input = @"password1234
p@ssW0rd1234
this is my regex
extended-gitleaks-config.toml
the word linguistical or babyproofing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}