import Foundation
let pattern = ##"(?i)[0-9a-z~!@#$%^&*\(\)\-_+=\|\}\{\]\[\;:\/?.,]{12,}(?:['|\"|\n|\r|\s|\x60]|$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
password1234
p@ssW0rd1234
this is my regex
extended-gitleaks-config.toml
the word linguistical or babyproofing
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)