re = /(?i)[0-9a-z~!@#$%^&*\(\)\-_+=\|\}\{\]\[\;:\/?.,]{12,}(?:['|\"|\n|\r|\s|\x60]|$)/m
str = 'password1234
p@ssW0rd1234
this is my regex
extended-gitleaks-config.toml
the word linguistical or babyproofing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end