import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)[0-9a-z~!@#$%^&*\\(\\)\\-_+=\\|\\}\\{\\]\\[\\;:\\/?.,]{12,}(?:['|\\\"|\\n|\\r|\\s|\\x60]|$)";
final String string = "password1234\n"
+ "p@ssW0rd1234\n"
+ "this is my regex\n"
+ "extended-gitleaks-config.toml\n"
+ "the word linguistical or babyproofing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}