const regex = new RegExp('(?i)[0-9a-z~!@#$%^&*\\(\\)\\-_+=\\|\\}\\{\\]\\[\\;:\\/?.,]{12,}(?:[\\'|\\"|\\n|\\r|\\s|\\x60]|$)', 'gm')
const str = `password1234
p@ssW0rd1234
this is my regex
extended-gitleaks-config.toml
the word linguistical or babyproofing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}