$re = '`(?i)[0-9a-z~!@#$%^&*\(\)\-_+=\|\}\{\]\[\;:\/?.,]{12,}(?:[\'|\"|\n|\r|\s|\x60]|$)`m';
$str = 'password1234
p@ssW0rd1234
this is my regex
extended-gitleaks-config.toml
the word linguistical or babyproofing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);