#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z]{3}[0-9,]{8,12}?)"
Local $sString = "AB# 33805717- 00 R/E FROM NA#52198052- 00" & @CRLF & _
"SOS 032122 TO 032122, TOTAL BILLED $2" & @CRLF & _
"OA FILMED UFE: 920220831200900" & @CRLF & _
"FILM NUMBER: VRG40947802 REC DATE: 070222" & @CRLF & _
"" & @CRLF & _
"FILM NUMBER AGILE:19517960 FSRECVDATE 062722" & @CRLF & _
"DIV ATL AUDIT NUMBER 44523104" & @CRLF & _
"FILM NUMBER: ATL34910475, DDE AGILE ID: 19517960," & @CRLF & _
"ROD NUMBER: 44523104, DIV: ATL," & @CRLF & _
"RCVD DATE: 06/27/2022"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")