use strict;
my $str = 'AB# 33805717- 00 R/E FROM NA#52198052- 00
SOS 032122 TO 032122, TOTAL BILLED $2
OA FILMED UFE: 920220831200900
FILM NUMBER: VRG40947802 REC DATE: 070222
FILM NUMBER AGILE:19517960 FSRECVDATE 062722
DIV ATL AUDIT NUMBER 44523104
FILM NUMBER: ATL34910475, DDE AGILE ID: 19517960,
ROD NUMBER: 44523104, DIV: ATL,
RCVD DATE: 06/27/2022';
my $regex = qr/([a-zA-Z]{3}[0-9,]{8,12}?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}