re = /([a-zA-Z]{3}[0-9,]{8,12}?)/m
str = 'AB# 33805717- 00 R/E FROM NA#52198052- 00
SOS 032122 TO 032122, TOTAL BILLED $2
OA FILMED UFE: 920220831200900
FILM NUMBER: VRG40947802 REC DATE: 070222
FILM NUMBER AGILE:19517960 FSRECVDATE 062722
DIV ATL AUDIT NUMBER 44523104
FILM NUMBER: ATL34910475, DDE AGILE ID: 19517960,
ROD NUMBER: 44523104, DIV: ATL,
RCVD DATE: 06/27/2022'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end