# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z]{3}[0-9,]{8,12}?)"
test_str = ("AB# 33805717- 00 R/E FROM NA#52198052- 00\n"
"SOS 032122 TO 032122, TOTAL BILLED $2\n"
"OA FILMED UFE: 920220831200900\n"
"FILM NUMBER: VRG40947802 REC DATE: 070222\n\n"
"FILM NUMBER AGILE:19517960 FSRECVDATE 062722\n"
"DIV ATL AUDIT NUMBER 44523104\n"
"FILM NUMBER: ATL34910475, DDE AGILE ID: 19517960,\n"
"ROD NUMBER: 44523104, DIV: ATL,\n"
"RCVD DATE: 06/27/2022")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.