using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]{3}[0-9,]{8,12}?)";
string input = @"AB# 33805717- 00 R/E FROM NA#52198052- 00
SOS 032122 TO 032122, TOTAL BILLED $2
OA FILMED UFE: 920220831200900
FILM NUMBER: VRG40947802 REC DATE: 070222
FILM NUMBER AGILE:19517960 FSRECVDATE 062722
DIV ATL AUDIT NUMBER 44523104
FILM NUMBER: ATL34910475, DDE AGILE ID: 19517960,
ROD NUMBER: 44523104, DIV: ATL,
RCVD DATE: 06/27/2022";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}