import Foundation
let pattern = #"([a-zA-Z]{3}[0-9,]{8,12}?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
AB# 33805717- 00 R/E FROM NA#52198052- 00
SOS 032122 TO 032122, TOTAL BILLED $2
OA FILMED UFE: 920220831200900
FILM NUMBER: VRG40947802 REC DATE: 070222
FILM NUMBER AGILE:19517960 FSRECVDATE 062722
DIV ATL AUDIT NUMBER 44523104
FILM NUMBER: ATL34910475, DDE AGILE ID: 19517960,
ROD NUMBER: 44523104, DIV: ATL,
RCVD DATE: 06/27/2022
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)