using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"utm_campaign=([^&]+)";
string input = @"utm_source=google&utm_campaign=Test | Test - Exact&utm_test=test";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}