const regex = new RegExp('utm_campaign=([^&]+)', '')
const str = `utm_source=google&utm_campaign=Test | Test - Exact&utm_test=test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}