import re
regex = re.compile(r"utm_campaign=([^&]+)")
test_str = "utm_source=google&utm_campaign=Test | Test - Exact&utm_test=test"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")