$re = '#utm_campaign=([^&]+)#';
$str = 'utm_source=google&utm_campaign=Test | Test - Exact&utm_test=test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);