#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)`\S*`"
Local $sString = "Here is a sample text having references to code items." & @CRLF & _
"Say it is a markdown file for instance holding a documentation." & @CRLF & _
"I may talk about how the `MyMethod()` function returns an " & @CRLF & _
"instance of `MyObject` that is helpful" & @CRLF & _
"in solving my problem."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")