using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`\S*`";
string input = @"Here is a sample text having references to code items.
Say it is a markdown file for instance holding a documentation.
I may talk about how the `MyMethod()` function returns an
instance of `MyObject` that is helpful
in solving my problem.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}