use strict;
my $str = 'Here is a sample text having references to code items.
Say it is a markdown file for instance holding a documentation.
I may talk about how the `MyMethod()` function returns an
instance of `MyObject` that is helpful
in solving my problem.';
my $regex = qr/`\S*`/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}