// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)`\S*`").unwrap();
let string = "Here is a sample text having references to code items.
Say it is a markdown file for instance holding a documentation.
I may talk about how the `MyMethod()` function returns an
instance of `MyObject` that is helpful
in solving my problem.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}