const regex = /`\S*`/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('`\\S*`', 'gm')
const str = `Here is a sample text having references to code items.
Say it is a markdown file for instance holding a documentation.
I may talk about how the \`MyMethod()\` function returns an
instance of \`MyObject\` that is helpful
in solving my problem.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}