$re = '/`\S*`/m';
$str = 'Here is a sample text having references to code items.
Say it is a markdown file for instance holding a documentation.
I may talk about how the `MyMethod()` function returns an
instance of `MyObject` that is helpful
in solving my problem.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);