#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)\",|\"Name\":\[)\"\K[^\"]*"
Local $sString = "{"Name":["Jobs","Bill"]}"
Local $sSubst = "******"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)