using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)\"",|\""Name\"":\[)\""\K[^\""]*";
string substitution = @"******";
string input = @"{""Name"":[""Jobs"",""Bill""]}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}