use strict;
my $str = '{"Name":["Jobs","Bill"]}';
my $regex = qr/(?:\G(?!^)\",|\"Name\":\[)\"\K[^\"]*/mp;
my $subst = '******';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";