re = /(?:\G(?!^)\",|\"Name\":\[)\"\K[^\"]*/m
str = '{"Name":["Jobs","Bill"]}'
subst = '******'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result