$re = '/(?:\G(?!^)\",|\"Name\":\[)\"\K[^\"]*/m';
$str = '{"Name":["Jobs","Bill"]}';
$subst = "******";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;