#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((http|https):\/\/)|www\.)+[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z^0-9]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)"
Local $sString = "http://google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"http://google.com/gaga" & @CRLF & _
"https://google.com/gaga" & @CRLF & _
"http://www.google.com/gaga" & @CRLF & _
"https://www.google.com/gaga" & @CRLF & _
"www.google.com/gaga" & @CRLF & _
"http://130.211.9.113" & @CRLF & _
"https://130.211.9.113/gaga" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ftp://google.com" & @CRLF & _
"130.211.9.113.de" & @CRLF & _
"google.com" & @CRLF & _
"google.com/gaga" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")