import re
regex = re.compile(r"(((http|https):\/\/)|www\.)+[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z^0-9]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)", flags=re.MULTILINE)
test_str = ("http://google.com\n"
"https://google.com\n"
"http://www.google.com\n"
"https://www.google.com\n"
"www.google.com\n"
"http://google.com/gaga\n"
"https://google.com/gaga\n"
"http://www.google.com/gaga\n"
"https://www.google.com/gaga\n"
"www.google.com/gaga\n"
"http://130.211.9.113\n"
"https://130.211.9.113/gaga\n\n\n"
"ftp://google.com\n"
"130.211.9.113.de\n"
"google.com\n"
"google.com/gaga\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")