import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((http|https):\\/\\/)|www\\.)+[-a-zA-Z0-9@:%._\\+~#=]{2,256}\\.[a-z^0-9]{2,6}\\b([-a-zA-Z0-9@:%_\\+.~#?&//=]*)";
final String string = "http://google.com\n"
+ "https://google.com\n"
+ "http://www.google.com\n"
+ "https://www.google.com\n"
+ "www.google.com\n"
+ "http://google.com/gaga\n"
+ "https://google.com/gaga\n"
+ "http://www.google.com/gaga\n"
+ "https://www.google.com/gaga\n"
+ "www.google.com/gaga\n"
+ "http://130.211.9.113\n"
+ "https://130.211.9.113/gaga\n\n\n"
+ "ftp://google.com\n"
+ "130.211.9.113.de\n"
+ "google.com\n"
+ "google.com/gaga\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}