// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(((http|https):\/\/)|www\.)+[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z^0-9]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)").unwrap();
let string = "http://google.com
https://google.com
http://www.google.com
https://www.google.com
www.google.com
http://google.com/gaga
https://google.com/gaga
http://www.google.com/gaga
https://www.google.com/gaga
www.google.com/gaga
http://130.211.9.113
https://130.211.9.113/gaga
ftp://google.com
130.211.9.113.de
google.com
google.com/gaga
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}