using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((http|https):\/\/)|www\.)+[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z^0-9]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)";
string input = @"http://google.com
https://google.com
http://www.google.com
https://www.google.com
www.google.com
http://google.com/gaga
https://google.com/gaga
http://www.google.com/gaga
https://www.google.com/gaga
www.google.com/gaga
http://130.211.9.113
https://130.211.9.113/gaga
ftp://google.com
130.211.9.113.de
google.com
google.com/gaga
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}