#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(one|three|four)\s*,\s*(?!\1)(one|three|four)\s*,\s*(?!\1|\2)(one|three|four)"
Local $sString = "one,three,four apple is red. should be match" & @CRLF & _
"" & @CRLF & _
"four, three, one orange is orange. should be match" & @CRLF & _
"" & @CRLF & _
"one,four,three the sky is blue. should be match" & @CRLF & _
"" & @CRLF & _
"one,two,four,three should not be match because two is between the group of words" & @CRLF & _
"" & @CRLF & _
"four,one,eight,green,three also not because eight and green is between the group of selected words"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")