re = /(one|three|four)\s*,\s*(?!\1)(one|three|four)\s*,\s*(?!\1|\2)(one|three|four)/
str = 'one,three,four apple is red. should be match
four, three, one orange is orange. should be match
one,four,three the sky is blue. should be match
one,two,four,three should not be match because two is between the group of words
four,one,eight,green,three also not because eight and green is between the group of selected words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end