const regex = /(one|three|four)\s*,\s*(?!\1)(one|three|four)\s*,\s*(?!\1|\2)(one|three|four)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(one|three|four)\\s*,\\s*(?!\\1)(one|three|four)\\s*,\\s*(?!\\1|\\2)(one|three|four)', 'g')
const str = `one,three,four apple is red. should be match
four, three, one orange is orange. should be match
one,four,three the sky is blue. should be match
one,two,four,three should not be match because two is between the group of words
four,one,eight,green,three also not because eight and green is between the group of selected words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}