import Foundation
let pattern = #"(one|three|four)\s*,\s*(?!\1)(one|three|four)\s*,\s*(?!\1|\2)(one|three|four)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
one,three,four apple is red. should be match
four, three, one orange is orange. should be match
one,four,three the sky is blue. should be match
one,two,four,three should not be match because two is between the group of words
four,one,eight,green,three also not because eight and green is between the group of selected words
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)