use strict;
my $str = 'one,three,four apple is red. should be match
four, three, one orange is orange. should be match
one,four,three the sky is blue. should be match
one,two,four,three should not be match because two is between the group of words
four,one,eight,green,three also not because eight and green is between the group of selected words';
my $regex = qr/(one|three|four)\s*,\s*(?!\1)(one|three|four)\s*,\s*(?!\1|\2)(one|three|four)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}