const regex = /\b(?:https?:\/\/)?(?:\w+\.)*website\.com(?!\/team|\/forum)\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:https?:\\\/\\\/)?(?:\\w+\\.)*website\\.com(?!\\\/team|\\\/forum)\\S*', 'gm')
const str = `https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www.website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com
test http://website.com test https://website.com/forum or website.com/test
https://www.test.com
https://sub.website.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}